[Samba] How to smbmount a share on a domain

jlm17 jlm17 at lucent.com
Fri Mar 7 15:33:10 GMT 2003

I'm running samba 2.2.5 on a RedHat 8 box. I need to mount a share from a PC
that is on a domain that the linux box is not a part of. Normally with another
PC you would specify your username as DOMAIN\user, how do I do this with
smbmount? I've looked at the documentation, google, etc. I can't find anything.
Is this even possible? Here's what I've tried:

smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=jlm17/ATRIA        
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=jlm17/ATRIA
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=jlm17 netbiosname=ATRIA
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=jlm17 netbiosname=ATRIA
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=ATRIA\jlm17            
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=ATRIA\\jlm17
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=ATRIA/jlm17 
smbmount //dd192/PM /h46/mvpen/jlm17/tmp -U ATRIA/jlm17      
smbmount //dd192/PM /h46/mvpen/jlm17/tmp -U jlm17      
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=jlm17/ATRIA workgroup=domain
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=jlm17%ATRIA workgroup=domain
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=jlm17%ATRIA                 
smbmount //dd192/PM /h46/mvpen/jlm17/tmp username=ATRIA%jlm17
smbmount //dd192/PM /h46/mvpen/jlm17/tmp -U ATRIA%jlm17      

All tries come back with the same error:

8351: session setup failed: ERRDOS - ERRnoaccess (Access denied.)
SMB connection failed

Those tries where I've used the -U also say:
/h46/mvpen/jlm17/tmp: invalid option -- U

This works trivially when logged into a PC locally just by supplying my username
as ATRIA\jlm17.

Any help would be appreciated.


More information about the samba mailing list