[Samba] win2000 service pack 4 - samba 2.2.2

ajcody at digitalhandshakes.com ajcody at ureach.com
Sat Jun 28 00:27:10 GMT 2003


 At 5pm today, we had an individual notify me that their 'profile' no longer was
accessible from the samba server (solaris 8 , smb 2.2.2). The person just had
their laptop reimaged and the new M$ service-pack 4 was installed on it.
They can access their 'home directory' just not the profile one. Error is
concerning the user not having access, versus rights. I installed the service
pack on my w2k machine and chmod 777 my profile directory as well...same error.
Defaults to the local profile instead. 

 Note, the samba server reflects "samba_server_hostname\username" when looking
at the permessions from windows. We also found out that the migrate win2kAD
accounts needed their profile directories on a windows machines to be changed as
well...they use to be, "nt4_domainname\username". Had to change take control of
the directory, therefore making the perms "win2k_ad\username". This then worked.
Sorry if I didn't explain this well.

 I'm not at work now, I can forward more details after dinner if needed.

Thanks for any help or confirmation that SP4 is a problem,
Adam Cody

More information about the samba mailing list