[Samba] Samba 2.2.7a - adduser script only worked the first time

Allen aseelye at blackfoot.net
Fri Jun 20 18:51:57 GMT 2003

>Allen írta:
>>I have WinXP machines loging into a samba domain. I am using this add user
>>add user script = useradd -d /dev/null -g 300 -s /bin/false -M %u
>>This worked beautifully with the first WinXP machine I set up. I immediately

>>booted up a second machine and got the "Access Denied" error. I have tried
>>more computers since and keep getting the same thing but the first machine
>>logs in and out fine. The samba.log keeps saying that the user does not exist

>>on the domain.
>>All of my WinXP machines were ghosted from the same image so I don't believe

>>the problem is on that side.
>>Any ideas?
>>Allen Seelye
>>Aseelye at blackfoot.net
>>ICQ# 8286205
>Sorry if it sounds fullish, but have you checked, that your computers don't
have all the same name, if you ghost them, you first need to change their names.

>Best Regards
>Geza Gemes

Actually that's not a stupid question, that happened when we first started using
Ghost. DOH!

But I did figured it out. We are using the serial numbers of the machines as
their computer names. Some of them start with letters and some of them start
with numbers. Linux doesn't won't allow usernames that begins with a number.
So when the add user script was running it would hit that name, fail to create
a system user, then smbpasswd couldn't enter it because there was no system
user, then windows would kick back an 'access denied' message. It would have
been nice for that to show up in the samba.log but it didn't. I found out by
manually entering the computer name at the console and seeing the 'invcalid
username' message.
We'll just have to modify our naming convention a little bit for the computers.

Thanks for the response though.
Allen Seelye
Aseelye at blackfoot.net
ICQ# 8286205

More information about the samba mailing list