[Samba] Can't access Samba Servers using cable internet access

Andrew Bartlett abartlet at samba.org
Tue Jun 17 04:50:28 GMT 2003

On Tue, 2003-06-17 at 14:02, Bobby Hitt wrote:
> Hello,
> Ever since adding Internet access to my cable account, I can no longer
> access several Samba servers on the Internet that I routinely accessed using
> my dialup account. I've tried using both the inetd server (with my cable IP
> address in the hosts.allow file. I can telnet, etc no problem, so I know
> it's working) and running smbd and smbd as daemons. When I try to access the
> Samba server, I watch the logs on the server, no warnings, errors, notices,
> etc., no indiation that I'm even attempting to access the server. I've tried
> using both the name in my /etc/hosts file, and also by IP address. As I said
> before, I had no problems using my dialup account.
> Can anyone shed ANY light on what's going on?

You should *never* place a Samba server on the public internet - it is
an inherit security risk.  If you have not yet upgraded to Samba 2.2.8a,
then you probably have been rooted too.

Either connect via a VPN, or connect with a more secure protocol - like

Many ISPs block ports 139 and 445 for this exact reason.

Andrew Bartlett

Andrew Bartlett                                 abartlet at pcug.org.au
Manager, Authentication Subsystems, Samba Team  abartlet at samba.org
Student Network Administrator, Hawker College   abartlet at hawkerc.net
http://samba.org     http://build.samba.org     http://hawkerc.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20030617/206f9ecd/attachment.bin

More information about the samba mailing list