[Samba] Can't seem to change "logon script = logon.bat"

Jason Jojo Account jojo at chem.ubc.ca
Wed Jun 11 21:35:53 GMT 2003


I am running RedHat 8 and have the same problem with both the distributed 
and updated samba RPMS (2.2.5 -> 2.2.7) and the source dist (2.2.8a).

I can seem to change many options but the "logon script = logon.bat" 
doesn't want to change. This is what I have in my smb.conf file :

...some stuff...
   logon script = %U.bat
   logon drive = H:

   comment = Initialization Scripts
   path = /path/to/netlogon
   root preexec = genlogon.pl %U %G %L %m %I
   readonly = yes
   guest ok = yes
   browseable = no

I have the genlogon.pl script in the /path/to/netlogon and is executable 
from the console.

When I run testparm I get the following (picked out relevent part) :

        logon script = logon.bat
        logon path = \\%N\%U\profile
        logon drive = H:
        logon home = \\%N\%U

        comment = Initialization Scripts
        path = /path/to/netlogon
        guest ok = Yes
        browseable = No
        root preexec = genlogon.pl %U %G %L %m %I

Now I would assume the logon script = in the testparm should read %U.bat 
not logon.bat. It seems that whatever I put there doesn't seem to alter 
it. I have tried things such as startup.bat, begin.cmd with no luck. But 
if there is a logon.bat script in it will run that no problem.

Also when I logon, it doesn't seem to execute the genlogon.pl script, but 
it executes fine if I run it from the Linux console.

Am I missing something ?? Has anyone experienced this ?? And if so, did 
you find a solution ?? Any thoughts and ideas are greatly welcome.


cheers - Jason :)

More information about the samba mailing list