[Samba] Re: Samba and ACLs

Dragan Krnic dkrnic at lycos.com
Wed Jun 11 18:24:48 GMT 2003

>I posted last week and got some good answers, but
>I am still having problems. Samba does not seem to
>be converting the acl's properly.  Here is an 

Perhaps you should enclose relevant parts of your
smb.conf file, the global section and the section
for the share in which you're not able to change

>If I run wbinfo -g or -u it lists all the groups or 
>users (respectively) in my domain. If I run a getfacl 
>on a file it prints out the correct acl's.  For 
>getfacl libattr-devel-2.0.8-3.i386.rpm
># file: libattr-devel-2.0.8-3.i386.rpm
># owner: MCASOLUTIONS\harris
># group: MCASOLUTIONS\Domain Users

This example doesn't show any ACLs! These are
normal permission bits as displayed by getfacl.
The command would show them even if ACL support
weren't there. Do some setfacl for some other
user or group and then do getfacl.

>However if I check a file through windows it 
>permissions show up as unix_group.gid
>Here are some screen shots:
>   http://bharris.f2o.org/win.html

>My theory is that samba is not properly converting 
>the linux ACLs into windows ACLs but I'm not sure
>how to fix it.  Any ideas?

It's too early for any theories. Do the homework 1st.

Get advanced SPAM filtering on Webmail or POP Mail ... Get Lycos Mail!

More information about the samba mailing list