[Samba] Re: pdf printer

Kurt Pfeifle kpfeifle at danka.de
Sat Jun 7 14:56:01 GMT 2003

Norman Zhang nzhang at arkon-group.com wrote on Samba-Digest

> Tue Jun 3 16:52:33 GMT 2003
> Hi,
>> > > But this only covers the "Install-PDF-Printer-on-CUPS" part.
>> > >
>> > > The other part is the "Install-PDF-Printer-on-Windows". Here you have
>> > > several options. My recommendation is the
>> > > "Use-the-CUPS-PostScript-Drivers-for-Windows-NT/2K/XP"
>> > > -and-export-with-the-help-of-cupsaddsmb" one.
>> >
>> > Sorry I'm still a little confused here. Can I do "cupsaddsmb -H
>> > PRNSERVER printer PDFPrinter" to setup PostScript driver (adist5.ppd)
>> > for Win9x/NT/2000, so users can download them from their personal
>> > workstations? If so, then I don't need to add arbitrary color laser
>> > printer from Windows?
>> I tried "cupsaddsmb -v PDFprinter", but system complaints that it cannot
>> find PDFprinter.ppd. I tried copy PDFprinter.ppd to almost every folder,
>> but still no luck. I'm doing this right? Where should I put
>> PDFprinter.ppd?
> I now have it working on NT/2000. But in 9x/ME, it complains that
> pdfprinter.PPD not found.

Try to use an 8-characters-only name for the PDF printer and it should be OK.
A hint about this was already provided at


the very first question "Win9x client can't install driver"...

> I checked WINNT40\0\, pdfprinter.PPD is in there.
> I even made duplicates like PDFPRINTER.PPD and pdfprinter.ppd, copied the
> file to a local disk, but 9x/ME still cannot find it. Could this be a bug
> somewhere? I don't know why I'm seeing all these strange cases 8(
> Regards,
> Norman

Kurt    [ sorry for not participating in the discussion of this problem during
           the last 7 days -- I was away on a business trip.... ]

More information about the samba mailing list