[Samba] Samba 2.8 and problems printing

Daniel Saraiva de Lacerda Costa dan_2 at mail.ru
Wed Jun 4 02:28:19 GMT 2003

Hi. Thank you for reading my first message :)

I installed SAMBA 2.8 yesterday in a computer running FreeBSD 4.7, with LPRng. Before installed that, I was using SAMBA 2.0.3 and all worked fine. But after the install (note that I´ve build the binaries from sources, not ported), SAMBA won´t share my printers. My network is comprised of one server running FreeBSD and 10 clients running NT 4.

I can still print from the server, running lpr -Phplaser <file>, so LPRng is working fine. The printcap file is located in /etc/printcap and my smb.conf is located in the same directory. When building the binaries, I didn´t modify the Makefile, so I don´t know if the smb.conf should be somewhere else (don´t believe so, because everything is working, auth, etc..).

At the moment I´m writing this e-mail, I´m away from the server, so I can´t try somethings I´ve figured out. 
1) I don´t have a "printcap name = /etc/printcap" in my smb.conf, nor "load printers = yes". Don´t know if this can solve my problem.

I´ve tried CUPS, but I installed in /usr/local/cups, using the --prefix=... when ./configuring it. Looking in the smbd.log I read the error message saying that access to the CUPS server was denied.. :P

Well, I accept any suggestions. Gotta make it work fast, hehe.

Thank you all!

More information about the samba mailing list