[Samba] Setting up a service with no authentication

Steve Heineck sheineck at northpacific.com
Thu Jul 31 19:47:33 GMT 2003

Samba Team,


Setting up Samba version 2.2.3a on an AIX 5.1 system.  I used an smb.conf
file from a previous system (Dynix/ptx) and got it working just fine after
changing from security = domain to security = user.  Here is my smb.conf:


# Samba config file created using SWAT

# from (

# Date: 2003/07/29 13:05:03


# Global parameters


        workgroup = NORTHPACIFIC.COM

        netbios name = HOODOO

        server string = Hoodoo(%h) Samba %v

        interfaces =

        security = user

        encrypt passwords = yes

        username map = /etc/smb_users.map

        log file = /usr/local/log/smb.%m.log

        max log size = 500

        local master = No

        domain master = False

        dns proxy = No

        remote announce =

        guest account = cyalpha

        preload = ar_export



        comment = Agility:dconv ar_export

        path = /ashland/dumpspace/auto/dconv/ar_export

        guest ok = yes

        force user = cyalpha

        read only = No

        create mask = 0666

        force directory mode = 0777

        map archive = No


The problem comes when I was trying to configure a specific service to allow
connection without authentication.  I tried several configurations around
"guest only", "guest ok" and "map to guest" suggested in the documentation
but nothing worked.  


The share is called ar_export and we are trying to access it directly with
an "MS access 2.0" application using the UNC \\hoodoo\ar_export
<file:///\\hoodoo\ar_export> .  I was able to get it to work if I changed
security = share and set guest ok = yes for that share but now I cannot
access any of my other shares.


What am I doing wrong?



Steve Heineck

North Pacific Group, Inc.


More information about the samba mailing list