[Samba] Samba 3.0.0beta3: Problem looking up SID of root

Paul Eggleton paule at cjntech.co.nz
Fri Jul 18 01:53:09 GMT 2003

Hi all,

I have just installed Samba 3.0.0 beta 3 on RH9, after uninstalling beta
2 (but keeping the smb.conf file the same). I am having a problem with
resolving the SID of root. I have "admin users = Administrator" set on
the single share I have set up so that Administrator performs as root.

Looking at a directory created in the share by Administrator on the
Windows client, which on the Samba server is owned by root, Windows
reports that it has an owner of the following unresolved SID:


Using wbinfo on the Samba server:

[root at beaker root]# wbinfo -S
[root at beaker root]# wbinfo -s
Could not lookup sid S-1-5-21-2120923204-611296470-4252591782-1000

If I run "getent passwd" there are lots of winbind-mapped entries, but
none for uid 10001. So it seems that it is the uid mapping for root is
broken in 3.0.0 beta 3, unless I have somehow made a mistake in the
upgrade. I am positive this was working fine with my beta 2 installation
- I could look at a folder on the share from Windows and it would
display MACHINENAME\root, not an unresolved SID. I have tried deleting
the winbind idmap tdb file but it doesn't help the situation.


Paul Eggleton                  Ph:    +64-9-4154790
Software Developer             Fax:   +64-9-4154791
CJN Technologies Ltd.          DDI:   +64-9-4154795
http://www.cjntech.co.nz       Email: paule at cjntech.co.nz

More information about the samba mailing list