[Samba] service terminated unexpectedly on WinXP clients with log level = 1

andrew fresh andrew at mad-techies.org
Sun Jul 13 03:57:37 GMT 2003

I am running Samba 3.0-beta2 as PDC on OpenBSD 3.3.  I have Windows XP clients that I need to serve I have reproduced this issue on both of them. Unfortunately when they boot, several services that get eventID's 7031 and 7034, they are both "The [service name] service terminated unexpectedly".  After I log in, I can start the services and it seems fine.  

It only does this when joined to the domain and plugged into the network. If I unplug the network cable when it boots, it works fine. Or if I don't have the XP box joined to the network.  

All machines worked fine with Samba 2.2.8a.

Now for the strange part,  I set the log level = 3 to try to debug the issue and the machines work perfectly. I set log level = 1 and they don't. I can do this by adding a -d 3 to the start command and it will also work if I actually change the setting in the smb.conf and don't put a -d on the command line.

I can do ethernet sniffing of the network during a working boot/login and the same when it doesn't if anyone needs that to help fix this. I can also send a level 3 log of it working, or a level 1 of it not working, I would like to send a level 3 of it not working, but it seems that is not an option I am given.

I don't want to run at log level 3 at all times!  Please help! If you need more information, please, let me know I am happy to provide it.

These are the services that don't start and their eventID:
(These are from a clean install of XP)
7034	Computer Browser 
7034	Cryptographic Services 
7034	DHCP Client 
7034	Logical Disk Manager 
7034	Error Reporting Service 
7034	COM+ Event System 
7031	Help and Support 
7034	HID Input Service 
7034	Server 
7034	Workstation 
7034	Messenger 
7034	Task Scheduler 
7034	Secondary Logon 
7034	System Event Notification 
7034	Shell Hardware Detection 
7034	System Restore Service 
7031	Themes 
7034	Distributed Link Tracking Client 
7031	Upload Manager service 
7034	Windows Time 
7031	Windows Management Instrumentation 
7034	Portable Media Serial Number 
7034	Wireless Zero Configuration 

I used this configure command to build samba, I also removed the -g from the LDFLAGS, LDSHFLAGS and WINBIND_NSS_LDSHFLAGS lines because without that my source/bin folder ended up over 500MB and without it is about 16MB.

env CPPFLAGS="-I/usr/local/include" \
    LDFLAGS="-L/usr/local/lib" \
                ./configure --prefix="/usr/local" \
                --libdir="/usr/local/lib/samba" \
                --localstatedir="/var" \
                --sbindir="/usr/local/libexec" \
                --disable-cups \
                --with-configdir="/etc/samba" \
                --with-lockdir="/var/spool/samba" \
                --with-piddir="/var/run" \
                --with-logfilebase="/var/log" \
                --with-privatedir="/etc/samba" \
                --with-swatdir="/usr/local/share/swat" \
                --with-ssl \
                --with-sslinc="/usr/include/ssl" \
                --with-ssllib="/usr/lib" \
                --with-libiconv="/usr/local" \
                --without-krb5 \
                --without-ads \
                --without-ldap \

This is for my home network, so I don't need kerberos, Active Directory or ldap, and since those required installing additional software, I disabled those features.

My samba config is a littly strange now as I tried setting different options to get it to work, all without success except for log level. I believe the server schannel = no is the main strange thing that is left.

Here is the config as testparm sees it

$ testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[netlogon]"
Processing section "[media]"
Processing section "[files]"
Processing section "[shared]"
Loaded services file OK.
Server role: ROLE_DOMAIN_PDC
Press enter to see a dump of your service definitions

# Global parameters
        workgroup = HOME
        server string = Samba Server (%v) on OpenBSD
        server schannel = No
        passdb backend = tdbsam, guest
        log level = 1
        log file = /var/log/smbd.%m
        max log size = 500
        time server = Yes
        logon script = scripts\logon.bat
        logon path =
        logon drive = U:
        domain logons = Yes
        preferred master = Yes
        domain master = Yes
        dns proxy = No
        wins support = Yes
        idmap uid = 10000-20000
        idmap gid = 10000-20000
        hosts allow = 192.168.1.,

        comment = Home Directories
        valid users = %S
        read only = No
        browseable = No

        comment = Network Logon Service
        path = /etc/samba/netlogon
        guest ok = Yes
        share modes = No

        comment = Media, Music and Movies
        path = /exports/media
        write list = @users
        read only = No
        force create mode = 0777
        force directory mode = 0777
        guest ok = Yes

        comment = Installers and Drivers
        path = /exports/files
        write list = @admins
        force create mode = 0775
        force directory mode = 0775
        guest ok = Yes

        comment = Files accessable to anyone
        path = /exports/files/shared
        write list = @users
        read only = No
        force create mode = 0777
        force directory mode = 0777
        guest ok = Yes

|   ICQ#   |             Proud Member of Mad-Techies.org              |
|  253198  |               http://www.mad-techies.org                 |
|        Computer Science: solving today's problems tomorrow.         |

More information about the samba mailing list