[Samba] samba-3.0.0beta2

vincent Badier vincent.badier at alcatel.fr
Tue Jul 8 09:42:01 GMT 2003

Hello all,

First, i present myself since this is the first time i post here. My name is 
Vincent Badier, and i'm a samba beginner. 

I tried to compil and install samba-3.0.0beta2. I configured it with the 
--with-acl-support and no error occured. The problem appear when i tried to 
join an active directory domain.

firstly :
# /usr/local/samba/bin/net ADS JOIN MEMBER -S mydc -Umyname
ADS support not compiled in

However the configure --help said on Optional Packages:
 --with-ads              Active Directory support (default yes)

ok, let's try without ADS option :
# /usr/local/samba/bin/net JOIN MEMBER -S ip.of.my.dc -Umyname
[2003/07/08 11:38:29, 0] rpc_client/cli_netlogon.c:cli_nt_setup_creds(249)
  cli_nt_setup_creds: request challenge failed
[2003/07/08 11:38:29, 1] utils/net_rpc.c:run_rpc_command(154)
  rpc command function failed! (NT_STATUS_INVALID_COMPUTER_NAME)
Create of workstation account failed
Unable to join domain MYDOM.

Arg, this is not good for me. 
Any idea?

PS : this is my smb.conf :
(I also tried to deal with lient lanman auth = Yes but without success)

# Samba config file created using SWAT
# from my.desktop.ip.addr (my.desktop.ip.addr)
# Date: 2003/07/08 10:37:38

# Global parameters
        workgroup = MYDOM
        netbios name = MYSRV
        server string = Samba 3.0.0beta2 
        interfaces = eth0
        security = DOMAIN
        password server = ip.of.my.dc
        client NTLMv2 auth = Yes
        client lanman auth = No
        client plaintext auth = No
        syslog = 0
        log file = /var/log/samba/log.smbd
        max log size = 8000
        show add printer wizard = No
        preferred master = No
        local master = No
        domain master = No
        dns proxy = No
        wins server = ip.of.my.dc
        ldap ssl = no
        invalid users = root

        path = /mnt/homes
        valid users = AD2+domain_users
        admin users = AD2+mynamevi /etc/sam	
        read only = No


More information about the samba mailing list