[Samba] directory does not exist?

Ed Sweetman ed.sweetman at wmich.edu
Mon Jul 7 17:32:30 GMT 2003

Holger Brückner wrote:
> any special characters in the directory names, like ä,ö,ü ?!?
> i had this effect with german umlauts:
> filneames where cut of at the position where the umlaut is placed. so
> this would result in windows trying to access filenames which are not
> there. 
> cya
> Holger Brueckner
> net-labs Systemhaus GmbH

Nope, plain ascii character directory names. Not even long ones. The 
directories exist and the filenames windows is trying to access (when in 
NT1 protocol) are correct. It's just showing up as a plain file instead 
of file folder. When using lanman2 and 1, they are seen as file folders, 
but nothing is inside them. I thought this had something to do with the 
kernel 2.5.x but cant seem to figure it out.

> On Mon, 2003-07-07 at 04:33, Ed Sweetman wrote:
>>Ed Sweetman wrote:
>>>I'm sure this has been brought up before but i searched through the last 
>>>few months of archives and i couldn't find any mention of it.  I've been 
>>>having this problem in debian unstable for the past few months and it's 
>>>seriously got me within 2 inches of deciding to invent a way to make 
>>>computer programs feal pain.  For some reason (my all anonymous access) 
>>>setup only lets you see the top level of a share and says all the 
>>>directories in it do not exist when you try to enter them.  I didn't 
>>>change the permissions of these directories since it worked so I take it 
>>> either it's something to do with something samba depends on that is 
>>>provided by debian or a configuration directive that has changed and i 
>>>do not have (though i doubt that).  I cant think of why this is 
>>>happening and i've been trying numerous versions with the same result. 
>>>Samba 2.2 does it and so does the latest 3.0.  I'm accessing from a 
>>>windows 98 machine.  Could this be a subtle networking error?

More information about the samba mailing list