[Samba] directory does not exist?

Ed Sweetman ed.sweetman at wmich.edu
Mon Jul 7 02:33:50 GMT 2003

Ed Sweetman wrote:
> I'm sure this has been brought up before but i searched through the last 
> few months of archives and i couldn't find any mention of it.  I've been 
> having this problem in debian unstable for the past few months and it's 
> seriously got me within 2 inches of deciding to invent a way to make 
> computer programs feal pain.  For some reason (my all anonymous access) 
> setup only lets you see the top level of a share and says all the 
> directories in it do not exist when you try to enter them.  I didn't 
> change the permissions of these directories since it worked so I take it 
>  either it's something to do with something samba depends on that is 
> provided by debian or a configuration directive that has changed and i 
> do not have (though i doubt that).  I cant think of why this is 
> happening and i've been trying numerous versions with the same result. 
> Samba 2.2 does it and so does the latest 3.0.  I'm accessing from a 
> windows 98 machine.  Could this be a subtle networking error?

The directories are being displayed as "file"'s instead of File Folders. 
   It's using the NT1 protocol.  If i try using LANMAN1 or 2 the 
filenames are all screwed up and the directories are seen as directories 
but nothing is shown within them.  They appear empty with size 0.  I'm 
using kernel 2.5.x... not sure how that would effect the server though.

More information about the samba mailing list