[Samba] Setting up Pointing and Click Printing through APW on Win2k Machine

Glenn Arnold garnold at unrealsolutions.com
Thu Jul 3 00:24:03 GMT 2003

First off I have read the SAMBA 2.2 printer documetation and Samba Printing Documentation for 3.0.  And searched the Internet through Google and did not come up with much.  Maybe it is how I am doing search I don't know. I had some success using CUPS for Point and Click printing using cupaddsmb command.  I could get the print drivers to download on W2K and XP.  But, I could not get the the Adobe Drivers to download to my Win9x machines.  When I tried to download the print drivers through APW to the Samba server you would see the drivers copy to the server, but when you click OK I get the message Printer settings could not be saved. Access is denied.  Here is the rights on my printer directory.

drwxrwxrwx   37 root     root         4096 Jul  1 20:12 Apps
drwx------    2 root     root        16384 Jun 22 10:44 lost+found
drwxrwxrwx    3 root     root         4096 Jun 24 17:12 netlogon
drwxrwxrwx    4 root     root         4096 Jun 27 18:49 printers

Here is the rights for the directories under printers
drwxrwxrwt    5 root     root         4096 Jul  2 19:58 w32x86
drwxrwxrwx    3 root     garnold      4096 Jul  2 19:31 win40

Here is rights for the directories under w32x86-- Notice __SKIP_0184
drwxrwxrwt    2 root     root         4096 Jul  2 19:20 2
drwxrwxrwt    2 root     root         4096 Jul  2 16:17 3
drwxrwxrwx    2 root     root         4096 Jul  2 19:58 __SKIP_0184

Also through W2K APW I tried to add printers that are not setup on the Red 9.0 linux box and created them trough APW I get the error message "Printer settings could not be saved. Access is denied."  I also noticed that this weird directory would pop-up in my printers directory it is named __SKIP_0184.  When adding the printer fails I click cancel and it disappears.  I truly believe it is rights issue I just do not know where to look.  My background is  in NT, so I just begun to start learning Linux and using for server applications. I have been real happy with Linux and Samba just stuck on this printer problem.  Also, I need some help with the addprinter command and delprinter command.  What goes after the command?  Most examples I see are addprinter command  is like this "addprinter = "  I know there is more to that command than this just blank.  Would some give me a good example of addprinter and delprinter command that works on Red Hat 9.  Here is my smb.conf file.


	netbios name = SERVER01
	workgroup = domain
	security = user
	os level = 64
	domain master = yes
	local master = yes
	prefered master = yes
	time server = yes
	unix extensions = yes
	encrypt passwords = yes
	domain logons = yes
	logon script = logon.bat
	wins support = yes
	character set = ISO8859-15
	client code page = 850
	veto files = /*.eml/*.nws/riched20.dll/
	lanman auth = yes
	add user script = /usr/sbin/useradd -d /ev/null -g ntmach -c 'Machine Account' -s /bin/false -M %u
	oplocks = yes
	load printers = yes
	printing = CUPS
	printcap name = CUPS
	addprinter command = /usr/sbin/redhat-config-printer-tui --Xadd-local
	path = /smbsrvr/netlogon/scripts
	read only = yes
	public = no

	comment = Home Directories
	valid users = %S
	browseable = no
	writeable = yes
	create mask = 0640
	directory mask = 0750
	hide dot files = yes
	veto files = /*.mp3/*.exe/*.com/*.js/*.bat/*.cmd/*.wsh/*.lnk/*.scr/.*/
	dos file times = yes
	valid users = @root
	path = /smbsrvr
	read only = no
	create mode = 0770
	directory mode = 0770
	force group = apps
	force directory mode = 0770
	dos file times = yes
	path = /smbsrvr/Apps
	read only = no
	create mode = 0770
	directory mode = 0770
	force group = apps
	force create mode = 0770
	force directory mode = 0770
	dos filetimes = yes

	comment = All Printers
	path = /var/spool/samba
	browseable = no
	writable = no
	printable = yes
	printer admin = root

	comment = Printer Drivers
	path = /smbsrvr/printers
	browseable = yes
	guest ok = no
	read only = yes
	write list = root
	create mask = 0755
	directory mask = 0777

More information about the samba mailing list