[Samba] Mandrake 9.0: rpcclient problem exporting printers to samba for windows

David Woodyard dwoody1 at airmail.net
Thu Jan 30 23:00:21 GMT 2003

I am new to CUPS, after working for 4 days to get printing from WinNT to 
Mandrake 9.0, I give up. Here is the problem:
the /etc/samba/smb.conf is setup with [printers] and [print$]. I copy the 
postscript drivers from adobe. I then tried to export a printer to samba with 
the following command
	cupsaddsmb -v -U dwoody canon

It did all of the commands successfully except for the last one. which was:
	rpcclient localhost -N -Udwoody%password -c 'setdriver canon canon'

I ran the same rpcclient standalone with debug and I got several error 
messages. They are
	1) connection refused on localhost:445 (it then used port 139 - should it?)
	2) WERR_ACCESS_DENIED (this was near the end of the output)

I have not been able to fix the first two errors. BTW, the drive shares are 
working correctly.
If anybody can help I will be very appreciative,


More information about the samba mailing list