[Samba] Problems making use of 2K PDC

Kenny Mann Kennymann at cdrobot.com
Wed Jan 29 21:47:09 GMT 2003

I'm having problems with samba using the 2K PDC.
I've gotten it to successfully join the 2K PDC via smbpasswd. Winbindd
is running and I can ping it. I've tried googling, but was unsuccessful
at finding something useful. The Windows 2K event viewer shows:

The session setup from the computer DATASRV failed to authenticate. The
name of the account referenced in the security database is DATASRV$.
The following error occurred: 
Access is denied.  

On my linux box, I'm using datasrv, does case matter?
My box is Lunar-Linux.
AMB Athlon XP 1700+
256MB PC2100 DDR Memory
40GB 7200 RPM hard drive. 2 partitions. 3.5GB and a 35.5 Everything is
installed on the 3.5GB

PDC is Windows 2000 Server
Compaq Prolient w/ 2GB of RAM & 20GB Ultra3 SCSI 15K RPM and 80GB 5400
IDE 5400RPM (yeah, I know it sounds funny but the big HD is just for
stale data... Mostly backup)

wbinfo -u gives

Wbinfo -t gives
Secret is good

Smb.conf is
  security = domain
  encrypt passwords = yes
  netbios name = Datasrv
  workgroup = CDROBOT
  log file = /var/log/samba/%m.log
  password server = mainsrv
  domain master  = yes
  os level = 65
  winbind separator = +
  winbind uid = 10000-20000
  winbind gid = 10000-20000
  winbind enum users = yes
  winbind enum groups = yes
  template homedir = /home/winnt/%D/%U

  comment = public
  path = /home/tmp
  read only = no
  public = yes

Testparm complains that the winbind separator might cause problems with
group memobship. I've tried using '-' and it stopped complaining, but
didn't fix the problem. I use '+' because it's used in the docs.

Has anyone experianced this?
Sometimes the users have problems signing on the the PDC saying that no
domain controller exist. Very weird, because after a few tries it seems
to work on 98/ME machines. 2K & XP seem to experience this as well, but
logon anyway.

If anyone needs more info, feel free to ask. TIA!


More information about the samba mailing list