[Samba] Win2k DC no longer authenticates for Samba shares (th at fixed it)

Gaffey, Mike MGaffey at fastekintl.com
Wed Jan 29 00:35:55 GMT 2003


-----Original Message-----
From: Paul Taylor
To: Michael Bartosh; Gaffey, Mike
Cc: 'samba at lists.samba.org'
Sent: 1/28/2003 4:46 PM
Subject: Re: [Samba] Win2k DC no longer authenticates for Samba shares

>Jan 27 19:25:51 mark smbd[13448]: [2003/01/27 19:25:51, 0]
>Jan 27 19:25:51 mark smbd[13448]:   2003/01/27 19:25:51 :
>change_trust_account_password: Failed to change password for domain

I've seen this error whenever I upgrade Samba; it appears to invalidate
the previous domain membership, even though I copy the secrets.tdb etc.
files across to the new version.

I think I've also seen it when I tried joining a domain that Samba was
already a member of - it cancels the previous membership?

The only workaround I've found to date is to delete the machine from the
domain on the domain controller, add it back and the join the domain
from Samba ("smbpasswd -j domain".)  The last step may not be strictly
necessary, but it confirms that Samba and the DC are on speaking terms

Any ideas on how to avoid these problems would be appreciated.


   Paul Taylor
   taylpm at si1.dod.gov.au

Thanks!!  I am also very interested in why that works and what causes the

More information about the samba mailing list