[Samba] File size limit = 2G?

Ed Struzynski eds at pdq.net
Tue Jan 28 17:24:13 GMT 2003

Hello All,


I'm running Samba 2.2.7a on RedHat 8.0. Connecting to a Windows 2000 

200GB share works OK, except for files > 2 GBytes.


The linux box can see the large Windows files, but does not see their

correct sizes -- it reports an absurdly big size when using ls -l. Files

that 2GB show up correctly. Trying to create a 3G file on the Windows box

from the linux box, using:


    dd if=/dev/zero of=/mnt/ntserver/bigfile bs=100M count=30


results in an error when the file hits 2G, with the error "file size

limit exceeded". Running the same command creating a file on the local

linux ext3 filesystem works OK.


Removing the Windows box from the equation, instead connecting to another

linux box running samba results in the same error. Creating a 3G file

on the same target system using NFS works OK, as does FTP.


So it appears that Samba supports large filesystems, but not large

files. Is this a configuration issue or a 32bit limitation in Samba??

I've tried samba-3.0alpha21-1 and it has the same problem.



Ed S.

More information about the samba mailing list