[Samba] more info - NT_STATUS_ACCESS_DENIED opening remote file

Paul Taylor taylpm at hydra.si1.dod.gov.au
Tue Jan 28 01:24:01 GMT 2003

On Jan 27, 10:33, Ben Scarbeau wrote:
> Subject: [Samba] more info - NT_STATUS_ACCESS_DENIED opening remote file
> Thanks to those who had suggestions on my last post, but none of those
> seems to have worked.  I have narrowed down the problem a bit though,
> seems users can't write to a share that is not their primary group.
> For example:  Bob's primary group is Bob and secondary group is Sally.
> Bob can write to the Bob group share but not the Sally group share.
> Anymore thoughts/suggestions.  Thanks again in advance.

After upgrading to Samba 2.2.7a, a couple of users complained about not
being able to access directories via group access - it worked fine in 2.2.0
Both of the affected users had 14 or more secondary groups - removing them
from some unnecessary groups got around the problem.

The number of groups _doesn't_ seem to be the whole problem, though - when
I tried to reproduce the problem with a test user and groups, it worked
fine.  The length of the group(s) name may be significant - I didn't
investigate this.  (I tried using smbclient with a higher debug level,
but it just spewing a bunch of meaningless numbers etc.)


   Paul Taylor
   taylpm at si1.dod.gov.au

More information about the samba mailing list