[Samba] Re: Can't add Machine account ( LDAP ) ...

C.Lee Taylor leet at leenx.co.za
Tue Jan 21 17:05:22 GMT 2003

     Just got bitten in the ass by not been able to join the domain with 

     Correct me if I am wrong, Jerry did give me a quick explaination.  It
has to do with usernames and what allowable characters  in it for security.

     Now, I need to fix this, does anybody have a patch/fix or tell me where
to look in the source to try and fix this.
     Finally was able to find the freaking message ... but I think that 
this might be something else ...

Message from Jerry ...
 >>where it should have been like this:
 > This is the alpha_strcpy() stuff again trying to remove "unsafe" shell
 > characters.
     If I understand what you where saying is, this is to do with shell? 
... But the query here is not shell based.

     I also tested today with the stuff in LDAP already ... and still 
seemed to running into problems ( kick oneself for not recording all the 
stuff I tried, which I will try in my LAB again )

     I have diff the samba-2.2.6 to samba-2.2.7a source to try and see 
what has changed, but I was not able to find anything ... ( the reason I 
used 2.2.6, is because Buchan Milne "bgmilne at cae.co.za" said that this 
worked in that version )

     Also, I have seen a few days old messages, which also seem to be 
discussing this problem ... but I was not able to follow that to and 
good end ...

     I really need domain joining, or at least a work around for it ... 
Please help me!!!


More information about the samba mailing list