[Samba] Second Post: Unable to add user with Samba 2.2.7 - LDAP - PDC

Buchan Milne bgmilne at cae.co.za
Fri Jan 17 12:03:01 GMT 2003

Matthieu Turpault wrote:
> Thanks for the answer
>>(BTW, are you using RPMs or not? If so, which ones please?).
> I use the RPM samba-common-ldap-2.2.7-1.1mdk, samba-server-ldap-2.2.7-1.1mdk
> and samba-client-2.2.7-1.1mdk.
>>>    workgroup = MDKGROUP
>>>    server string = Samba Server %v
>>>    log file = /var/log/samba/log.%m
>>>    max log size = 5000
>>>    security = user
>>>    encrypt passwords = yes
>>>    ldap admin dn = "cn=manager,id=1"
>>Should this not be something like 'ldap admin dn =
>>"cn=manager,o=comelis"? Or does :
>>$ ldapsearch -x -h ldap.comelis.fr -D "cn=manager,id=1" -W "(uid=mat)"
>>work for you (with the password you have added to samba with 'smbpasswd
>>-w <password> when prompted)?
> Yes, it does ! My base dn is "id=1".

Didn't appear so from the LDIF entry you posted ... the dn didn't
contain 'id=1'.
> But I *can* log with a user, i.e. a valid credential stored in the
> directory. My computer *can* contact the PDC... and it worked with
> samba-common-ldap-2.2.3a-10mdk..

Works for me on 9.0 using 2.2.7a-3mdk (ie I can see users in Computer
Management->Local Users and Groups when I add domain users to a local
group). Also worked on 8.2 with everything from 2.2.3a up to 2.2.7a.

Have you tried looking in the logs (maybe increase the log level also)?

I will be releasing new RPMs soon hopefully, just want to try and track
down why the 'add user script' isn't being run when trying to join a
machine to the domain.


|--------------Another happy Mandrake Club member--------------|
Buchan Milne                Mechanical Engineer, Network Manager
Cellphone * Work            +27 82 472 2231 * +27 21 8828820x121
Stellenbosch Automotive Engineering         http://www.cae.co.za
GPG Key                   http://ranger.dnsalias.com/bgmilne.asc
1024D/60D204A7 2919 E232 5610 A038 87B1 72D6 AC92 BA50 60D2 04A7

More information about the samba mailing list