[Samba] Issue with adding machines to domain

Luke Bowerman luke at newmediaarts.org
Tue Jan 14 07:56:00 GMT 2003

Okay, here's the situtation I have a samba server (2.2.3a) which is the
PDC for a domain with approximately 60 windows 2000 clients. 

Up until recently I haven't had any problems with using it for roaming
profiles and domain authentication, however since last thursday I have
not been able to successfully create machine account that would work.
When following the procedure that has worked before just fine on this
server in the past the Windows 2000 machine takes 3-4 minutes to respond
(the "add to domain" window is completely non-responsive) and then I get
a perky message back saying "You machine has been added to the CHS
domain." When I restart and attempt to logon to the domain I get a
message saying the domain could not be found.

The entry in /etc/samba/smbpasswd looks like this:


I have tried this on a variety of different systems (all 2000), systems
that have been on the domain before (I removed and then attempted to
re-add them), systems that have never been on the domain, and brand new
installs on brand new hardware.

Machines still attached to the domain can log in, browse the network,
and use roaming profiles perfectly.

For the life of me I swear I've gone through everything I can think of
that would cause something like this to no avail. Any help that you
folks can offer me would be greatly appreciated.

Luke Bowerman
Olympia School Distict - Olympia, WA

More information about the samba mailing list