[Samba] Automatic Printer Driver Download Access Denied

Frank Ling ling at atd.ucar.edu
Thu Jan 9 18:24:01 GMT 2003


Thanks for the reply.

I don't use PRINTING WITH CUPS in our samba servers. I guess "add printer command" in smb.conf is not needed.

I have two Samba 2.2.2-pre samba servers with Windows workgroup network. They are all capable to do automatic printer driver downloading. We are in the process of Windows 2000 active directory migration, so the Samba with automatic printer driver downloading capability is very much needed.  

I just guess the problem could be from Windows side. It could be the problem from the domain membership. Our domain infrastructure is a single domain with multiple OUs. I am one of OU admins. Because I could see the printer drivers were uploading to the Unix directory, but got the denial from Windows Adding Printer Wizard when I tried to apply the change to the property of the printers.  After I click the Printer from the Samba share, I could see two accounts from the security tab windows from the printer property on Samba printer. One account called "Everyone"; the other is a long list of number such as "S-1-5-21-78936058-1897051121-725345543-500". I guess this is the SID of the account that I current use. And this account allows to "Print, Manage Printers, and Manage Document". It could also be the compatibility problem of Windows 2000 AD and Samba 2.2.x.

Frank Ling
System Administrator
ling at ucar.edu

Do you have=20
add printer command=3D <youraddprinterscript>
in smb.conf ?
my looks like:
# Script zum anlegen eines Sambadruckers mit cups
#$1 =3D Ausf=FChrlicher Druckername
#$2 =3D Drucker/Queue/Share-Name
#$5 =3D Ort des Druckers
/usr/sbin/lpadmin -p "$2" -D "$1" -L "$5"
echo "Samba Printer Port"
the generated printer has to be modified with the cups
web interface to confirm the right interface to the printer:
/dev/lp0 or something else.


> I have a problem for implementing automatic printer driver download on
> Samba 2.2.7a. When I tried to upload printer drivers from a Windows 200=


>> client, I could see the printers were uploaded to the printer driver
>> directory W32X86 under Unix. However, When I tried to apply those
>> changes to the printer driver, I got =93printer settings could not be
>> saved, Access is denied=94.
>> The samba is Samba 2.2.7a on a Linux. I tried on Solaris version also,
>> but I got the same result. Here is some information from smb.conf:
>> [global]
>> printer admin =3D @rdp,atdadmin,help
>> [print$]
>>     path =3D /etc/samba/pdrivers
>>     guest ok =3D yes
>>     browseable =3D yes
>>     read only =3D yes
>>     write list =3D @rdp,help,atdadmin
>> 5 rerun:/etc/samba-> ls -al
>> total 84
>> drwxr-xr-x    3 root     root         4096 Jan  7 15:01 ./
>> drwxr-xr-x   72 root     root         8192 Jan  7 15:12 ../
>> -rw-r--r--    1 root     root           20 Dec 11 02:32 lmhosts
>> drwxr-xr-x    3 atdadmin root         4096 Nov 15 14:24 pdrivers/
>> -rw-r--r--    1 root     root          776 Dec 11 02:32 recycle.conf
>> -rw-r--r--    1 root     root          120 Dec 11 02:32 samba-block.con=

>> -rw-------    1 root     root         8192 Jan  7 15:01 secrets.tdb
>> -rw-r--r--    1 root     root        10667 Oct 29 11:53 smb10-29-02.con=

>> -rw-r--r--    1 root     root        15571 Jan  7 15:01 smb.conf
>> -rw-r--r--    1 root     root        10731 Oct 16 13:02 smb.conf.rpmnew
>> -rw-------    1 root     root          666 Dec 31 15:52 smbpasswd
>> -rw-r--r--    1 root     root           97 Dec 11 02:32 smbusers
>> The samba was on a Windows 2000 active directory. It acted as a member
>> server for files/printing. I used =93atdadmin=94 account for doing uplo=

>> printer drivers from a Windows 2000 client machine.
>> Please help!
>> Frank

-------------- next part --------------
HTML attachment scrubbed and removed

More information about the samba mailing list