[Samba] (no subject)

Terry Davis tdavis at approbation.org
Thu Jan 9 01:39:00 GMT 2003

I just ran across this myself.  I guess I dont understand why there
needs to be machine names in /etc/passwd if you are storing everything
in LDAP.  Am I missing a configuration option here?   Can one of you
samba geniuses point me in the right direction please?

Thank you!

>I have exactly the same bug.  Your original email was dated 24 May 2002
>so I can safely assume that either you solved the problem or have since
>been institutionalized. ;-)
>Anyway, I sure could use your help.
>Jim C.
>> Dear samba guru,
>> I have a little bug i can't solve. It is pretty misterious to me,
>> must be a problem how samba execute the add user script. Now here
>> is the situation. I've compiled samba 2.2.4 with ldap 2.0.23 to run
>> as PDC with win2k workstations. Everything works as expected except
>> the add user script to add workstation automaticly to the domain.
>> add user script = /usr/local/sbin/smbldap-useradd.pl -w %u
>> This script is working fine when i run it in command line. But
>> when it's executed by samba when trying to join the domain, it
>> fails in a weird way. Here is the log :
>> [2002/05/16 14:34:34, 0] passdb/pdb_ldap.c:pdb_getsampwnam(777)
>>   LDAP search "(&(uid=yannick-2k_)(objectclass=sambaAccount))"
>returned 0
>> entries.
>> [2002/05/16 14:34:34, 0] rpc_server/srv_netlog_nt.c:get_md4pw(176)
>>   get_md4pw: Workstation yannick-2k$: no account in domain
>> [2002/05/16 14:45:48, 0] passdb/pdb_ldap.c:pdb_getsampwnam(777)
>>   LDAP search "(&(uid=yannick-2k_)(objectclass=sambaAccount))"
>returned 0
>> entries.
>> [2002/05/16 14:45:49, 0]
>> rpc_server/srv_samr_nt.c:_api_samr_create_user(1929)
>>   User yannick-2k$ does not exist in system password file (usually
>> /etc/passwd). Cannot add account without a valid local system user.
>> I also tried the unix passwd sync parameters, and got some other
>> that are unresolved since i posted them a couple days ago.
>> (Samba+PDC+LDAP (add user script + unix passwd sync) Can't call perl
>> There is just something i don't get (how samba are executing the
>> since they are working in command line!).
>> A little hand would be appreaciated!
>> Thanks,
>> Yannick Tousignant
>> ======================
>> Network Administrator
>> OKA Computer Systems ltd.

Terry Davis

More information about the samba mailing list