[Samba] Autocad file corruption...

David Brodbeck DavidB at mail.interclean.com
Wed Jan 8 21:12:00 GMT 2003

> -----Original Message-----
> From: Robert A Wooldridge [mailto:bob.wooldridge at edm-inc.com]

> I am having problems with autocad file corruption.  My users are
> draftsman and access project files via samba over the network.  This
> problem occurs after a file has been worked on and someone 
> attempts open
> a file that they were working on.  There is no indication of a problem
> while the file is open and being worked on.  But when they try to
> re-open it, autocad thinks the file is corrupt and it cannot be
> salvaged.

I had a similar problem for a while.  Users were being locked out of their
AutoCAD files until they rebooted, and there were occasional instances of
corruption.  It turned out to be a network problem.  The user was on a badly
overloaded hub, and dropped packets were causing problems.  Duplex
mismatches could also do it, but you said you already ran diagnostics, so I
assume you've checked that the NICs and the switch/hub are both set to the
same duplex settings.  (Watch out, some older equipment doesn't
auto-negotiate properly, requiring all NICs to be manually forced into the
proper mode.)  I haven't had a single instance of AutoCAD file corruption
since all our AutoCAD users were moved to a fully switched network, for what
it's worth.

If you can't find a network problem, you might try disabling oplocks on the
samba server to see if it helps.

More information about the samba mailing list