[Samba] Profile privelege problem

Bill.Light at kp.org Bill.Light at kp.org
Mon Dec 15 06:15:37 GMT 2003

This problem appears to have been discussed before, but none of the 
offered suggestions have been any help.

Situation:  I had a working Samba PDC, using SuSE 7.3 Professional  (I 
believe 2.4.16 Kernel) and I do NOT know what version of Samba.   Then my 
hard disk died..

Rather than re-build another 7.3 box (SuSE is dropping support December 
15th) - I used the latest and greatest SuSE 9.0 Professional...I then 
installed all the latest patches via YaST.  That gives me a kernel of 
2.4.21 (-144 in SuSE speak) and Samba 2.2.8a

I had the configuration backed up on another box, so I used that as the 
base for Samba 2.2.8a.  I have tried chmod, chown of various directories, 
making profile world readable, writeable, executeable, all to no avail.  I 
have tried commenting out various lines as suggested by other posts...also 
to no avail.

W2K reports it can not find roaming profile, and then also reports it can 
not find a local profile, and signs the user (any user) on with a "temp" 
profile.  All drive mappings are available, just no profiles, recent 
lists, etc...

Samba log is showing:  api_samr_set_userinfo: Unable to unmarshall 

bumping the samba log level, verifies that I am going after the user 
profile and I am "dying" because of lack of priveleges....yet I can ssh 
into the box as a user and read or touch or execute anything I want !?

What am I missing ???

More information about the samba mailing list