[Samba] Re: "User may Log On To These Workstations" does not work

Eddie temp_storage2002 at yahoo.com
Thu Dec 11 15:12:22 GMT 2003

"Beast" <indorama at rad.net.id> wrote in message
> Thursday, December 11, 2003, 7:28:18 AM, Kristyan wrote:
> > Hiya,
> > Have a look at the "announce as" parameter.
> afaik, this will not solved this problem. announce as is only
> announcing samba server as Win OS version.
> to solve, just add smb server name to allowed w/s for *every* nt user
> or don't use it at all.

Thanks much for the pointers.  I changed the samba fileserver to announce
itself as "NT Workstation, version 4.0," and then added the workstation name
(RHL9) explicitly to the list of workstations that the user is permitted to
log on to.  This did not solve the problem as the user could still not
access the samba workstation's (RHL9's) shares.  The user received a "User
not permitted to log on to this workstation" error when they tried to

Could it be a problem with my configuration of the machine (included below)?
Or perhaps the configuration of my samba 3.0 PDC?

Load smb config files from /etc/samba/smb.conf
Processing section "[tmp]"
Loaded services file OK.
Press enter to see a dump of your service definitions

# Global parameters
        workgroup = NTDOMAIN
        netbios name = RHL9
        server string = Samba Workstation (v%v on %h)
        security = DOMAIN
        passdb backend = tdbsam:/etc/samba/passdb.tdb
        log level = 1
        log file = /var/log/samba/log.%m
        max log size = 100
        announce version = 4.0
        announce as = NT Workstation
        socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
        addprinter command = csh -c 'echo \"Add printer command not yet
implemented on %L!\" | /usr/bin/smbclient -M %m' &
        deleteprinter command = csh -c 'echo \"Delete printer command not
yet implemented on %L!\" | /usr/bin/smbclient -M %m' &
        add user script = /usr/sbin/useradd -m -s /bin/false '%u'
        delete user script = /usr/sbin/userdel -r '%u'
        add group script = /usr/sbin/groupadd '%g'
        delete group script = /usr/sbin/groupdel '%g'
        add user to group script = /usr/bin/gpasswd -a '%u' '%g'
        delete user from group script = /usr/bin/gpasswd -d '%u' '%g'
        set primary group script = /usr/sbin/usermod -g '%g' '%u'
        add machine script = /usr/sbin/useradd -n -g machines -c Machine -d
/dev/null -s /bin/false '%u'
        dns proxy = No
        add share command = csh -c 'echo \"Add share command not yet
implemented on %L!\" | /usr/bin/smbclient -M %m' &
        change share command = csh -c 'echo \"Change share command not yet
implemented on %L!\" | /usr/bin/smbclient -M %m' &
        delete share command = csh -c 'echo \"Delete share command not yet
implemented on %L!\" | /usr/bin/smbclient -M %m' &
        invalid users = bin, daemon, adm, sync, shutdown, halt, mail, news,
uucp, operator, gopher
        printer admin = administrator
        hosts allow = 192.168.144., 127.
        min print space = 2000
        print command = /usr/bin/lpr -P%p -r %s

        comment = Temporary file space
        path = /tmp/samba
        read only = No
        guest ok = Yes

More information about the samba mailing list