[Samba] SOLVED Samba 3.0.0, CUPS support - "Unable to open printcap file cups for read!"

Fran Fabrizio fran at cis.uab.edu
Tue Dec 9 23:56:56 GMT 2003

> I have set "Printcap /dev/null" in cupsd.conf and re-started cupsd first
> then smbd. Guess what? "smbclient -L localhost" still lists all my
> printers! And I can still print from my Windows apps. (I can't print
> anymore from OpenOffice, since that one *does* look for a printcap....)

In desperation I tried "printcap = /etc/printcap" even though the HOWTO
recommended "printcap = cups" and Kurt's advice above is that you could
even redirect to /dev/null.  Guess what, it worked.  At least on my
install, it seems to require that you do have a real, live printcap even
for CUPS printing support.  I then added another printer via the redhat
printer config tool, which added it to CUPS.  I restarted smb and the
new printer showed up on my Windows clients.  So, the residual question
is why does it require a real printcap file even under CUPS support? 
The docs don't seem to feel that it should.

Now I need to solve the "You do not have sufficient access to your
computer to connect to this printer" problem from the Windows clients.

Thanks for the help,

More information about the samba mailing list