[Samba] rpcclient / adddriver returns WERR_ACCESS_DENIED

Arnst, Rainer Rainer.Arnst at ee-consultants.de
Tue Dec 9 09:59:20 GMT 2003


I am trying to prepare downloadable printer drivers for Windows-Clients
with Samba 3.0.0-final. Everything worked fine so far. But I found no
way to add the printer driver files to the samba database. The method
using the Add Printer Wizard in W2k did not work for me.

This is what I tried:

linux4:/# rpcclient -U'root%secret' -c 'adddriver "Windows NT x86"

Any "hints" are very welcome!!

Have a nice day!

This is my smb.conf:
# Samba config file created using SWAT
        workgroup = ENTWICKLUNG
        netbios name = LINUX4
        server string = %h server (Samba %v)
        encrypt passwords = true
        passdb backend = tdbsam guest
        obey pam restrictions = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n
*Retype\snew\sUNIX\spassword:* %n\n .
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        dns proxy = No
        panic action = /usr/share/samba/panic-action %d
#       invalid users = root
        hosts allow = all
        printing = cups
        load printers = yes
        printer admin = root,arnstr,guest
        printcap name = cups

        comment = All Printers
        path = /var/spool/samba
        browseable = no
        public = yes
        guest ok = yes
        writable = yes
        printable = yes
        printer admin = root,arnstr,guest

        comment = Printer Drivers
        path = /etc/samba/drivers
        browseable = yes
        guest ok = yes
        read only = yes
        write list = root

   comment = Home Directories
   browseable = no

More information about the samba mailing list