[Samba] Single File Delete/Directory Listing on Windows ME

Brett Johnson brett at hypertronic.com
Sat Dec 6 23:35:52 GMT 2003


I'm having a really odd problem with some Windows ME stations connected to a
Samba server.  From a command prompt on the ME stations, I do the following:
dir *.*
This works as expected, all the files in the directory are displayed.  I
then do:
dir test.txt

And I get:

General failure reading drive G
Abort, Retry, Fail.

The directory contains the file, and the file shows up in a full listing,
but I can't do a listing of a single file. Also affects the del command.  I
can delete any number of files using wildcards, but I can't delete just one
file.  From Explorer, I can delete a single file, but not from the command

It works fine on my Windows 2000 stations.  I've tried 3 different Fedora
Servers running Samba 3.0015 and many different Windows ME stations, and
they all have the same problem.  Servers running Redhat 9 and older Samba
versions appear to work fine.  I've tried everything I can think of in the
samba config files and nothing seems to work.  Any help will be greatly

Thanks in advance

More information about the samba mailing list