[Samba] RH 9, Samba 2.2.8 and Mac OS X Clients

Tom Schaefer schaefert at tomcat.umsl.edu
Wed Dec 3 21:15:30 GMT 2003

Welcome to the club.  Yes, I experience that exact same issue with Mac OS
10.2.x and like you was waiting for 10.3 which I got to try for the first
time today.  Like you it didn't fix anything.  Its crazy.  As you say
everything works fine if you drop to a shell prompt you can do all the cp
-r, mv, rm whatever you want but in the GUI you get insufficient
privileges errors. Yes, to Windows 2K systems its fine.  In fact I know
first hand Mac OS 10 - 10.1.x to my Samba server are fine.  From a post I
found elsewhare I gather 10.2 is fine but then it all got mucked up with
the subsequent releases 10.2.x and now 10.3.

I originally posted about this problem back in early July.  Now in my case
its not Redhat, its Sparc/Solaris and the weird weird thing about it is
that its only a problem if I'm running a Samba compiled for Sparc as a
64bit app.  A 32bit compile of Samba keeps the Macintoshes happy but thats
really not an option for me due to a bug in Solaris where if you are
running a 32bit samba you are limited to 255 users which is not nearly
enough in my case.

Back in July I thought it was probably a Sun problem.  But since then I've
gathered up a bunch of postings, mostly from www.apple.com/support (most
of which have expired off that server but I still have copies) of people
describing these exact same symptoms on Redhat, Suse, Gentoo, Mandrake,
and FreeBSD, and possibly IRIX (the guy wasn't specific enough to say for
sure).  And now that I think about someone I work with was in touch with
another site running Solaris like us and having the same problem.

Something is up.  I don't know if its an Apple problem or something in
Samba.  All I know is its been broke quite a while - at least for a
scattering of cursed souls like you and me.  I tried Samba on Redhat back
in July to see if I could replicate the problem I was having with Mac OS
10.2.x clients to Solaris.  In my experiment Redhat worked fine, go
figure, thats why I thought it was a Sun problem until I've seen all the
subsequent posts like the one from yourself.

If you figure out anything about it whatsoever please drop me a note as
this is about to become a HUGE headache for me as the university I work
for just bought a classroom full of these OS 10 boxes and expect the
students to be able to mount their disk space just like how they get a
mapped drive letter served out from Samba to the PCs.  So I'm scrambling
for a solution.

Tom Schaefer
UNIX Administrator
University of Missouri Saint Louis

On Thu, 06 Nov 2003 17:15:42 +0000
Jinn Koriech <samba at postie.com> wrote:

> Been having very similar problems on RedHad-7.3 with Samba 2.2.7-3.7.3.
> Currently users can create folders, but they can't copy files.  An entry
> is created for the file on the server, but no data ever gets transfered.
> I've found that if you manipulate the files from the Terminal there is
> no problem.  That is, cp, mv, touch all work fine in the terminal.  
> I conclude that it is the Aqua interface.  I found that while native
> Aqua apps can't get a handle on the shares, an app such as jEdit on OSX
> _does_ work without a glitch.
> I waited for OSX 10.3 (panther) to come out in the hope that the problem
> would be resolved, but no luck!  Still broken!
> On the other hand, it appears that shares from a Windoze 2000 Server
> work fine, so I'm not sure what to make of it - is it a Samba issue or
> an Apple problem?
> Does anyone else experience anything like this?
> Jinn
> On Tue, 21 Oct 2003 09:00:20 +0200, Götz Reinicke wrote:
> > Hi,
> > 
> > we run a RH9 samba 2.2.8 ext3 Server and have some problems with MacOS
X > > Clients: They aren't allowed to write directories containing files
to > > any of our shares.
> > 
> > I connect to the sambaserver with smb://servername/sharename and a
samba > > user. This user is allowed to create new folders and he can copy
files > > into this folder.
> > 
> > But if he tries to copy the local folder containing files to the share
> > or into a newly created folder on this share, ther is an errormessage 
> > saying, that the user has not the necessary access rights.... :-(
> > 
> > An other RH9 Server with samba 2.2.8 did'nt have this problem....
> > 
> > I controlled the writelist option, the directory permissions.
> > 
> > Any ideas??
> > 
> > Thanks
> > 
> > Götz Reinicke
> > 
> > -- 
> > Götz Reinicke
> > IT Koordinator - IT OfficeNet
> > 
> > Tel. +49 (0) 7141 - 969 420
> > Fax  +49 (0) 7141 - 969 55 420
> > goetz.reinicke at filmakademie.de
> > 
> > Filmakademie Baden-Württemberg
> > Mathildenstr. 20
> > 71638 Ludwigsburg
> > www.filmakademie.de
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list