No subject

Mon Dec 1 11:34:25 GMT 2003

for users defined on the PDC.

However, I am setting up a second Samba server and want it to
join the domain so I can use "security = domain".  Lets call
the PDC samba1 and the new samba client samba2.  ON samba 1, I did:

useradd -c 'Samba2 SAMBA' -d /dev/null -M -g 202 -s /bin/false -u 1503 samba2\$
passwd -l samba2\$
smbpasswd -a -m samba2\$

to create the trust account.

Then on samba2, I run:

  smbpasswd -j DOMAIN -r samba1 -UAdministrator -D4

and get

Connecting to at port 139
session setup ok
Domain=[DOMAIN] OS=[Unix] Server=[Samba 2.2.2]
Unable to join domain DOMAIN.

I have tried various log levels on both boxes but got nothing illuminating
except the following on the PDC's samba2.log file:

[2002/04/23 12:05:43, 3] rpc_server/srv_lsa_hnd.c:close_policy_hnd(182)
  Error closing policy

Both machines are running samba 2.2.2 on Linux RH7.1 machines.

samba is NOT running on samba2 when I try the smbpasswd command.
I tried erasing the MACHINE.SID and secrets.tdb files before running
the smbpasswd command.  Afterwards, there is a new secrets.tdb file but
it still fails.

If I set up samba2 to use "security = server" and "password server =
samba1" it seems to work okay getting passwords from samba1 and allowing
clients to mount shares.  Is there any advantage to using "security =
domain" in this setting anyway?

Paul Raines                  email: raines at
MGH-NMR Center.              tel:(617)-724-2369
149 (2301) 13th Street       fax:(617)-726-7422
Charlestown, MA 02129	USA

More information about the samba mailing list