[Samba] Seeking advice: Backup Exec & Samba shares

Chuck Stuettgen cstuettgen at myrealbox.com
Mon Dec 1 00:35:57 GMT 2003

On Sun, 2003-11-30 at 13:28, McKeever Chris wrote:
> On Sat, 29 Nov 2003 19:18 , Bruce Lane <kyrrin at bluefeathertech.com> sent:
> >Fellow Samba-shakers,
> >
> >	I've run into an odd problem, and I'm seeking the advice of anyone who has implemented Veritas Backup Exec 8.6 or 9.0, on an NT 4.0 server platform, 
> to perform backups of NetBSD 1.6x systems via Samba file shares. Said problem did NOT manifest itself until I tried using Samba 3.0.0. I have jumped back to 2.2.8a, 
> since that's the last version that was known to work, until I can get the issue resolved.
> >
> >	And the issue is: When I try to browse Samba-produced file shares, it takes nearly two and a half minutes for the tree to expand. Then, when I try to 
> select one of the branches in the directory tree for backup, I get a Dr. Watson error (an Access Violation exception), an additional error message that the program 
> could not browse the share because the Remote Procedure Call failed, and the Backup Exec master job engine shuts down. I have to restart it before I can do 
> anything else.
> >
> I posted about this, as well as opened up a tech-ticket with VERITAS.  Recommendations on the list seemed to show that not many are using Backup Exec.  VERITAS 
> answer is that you can not connect directly to a Samba share from the BACKUP EXEC explorer, not can you force it by manually typing it (text view).  They do have a 
> BE-AGENT for RH7.3.  I have used it with little success, seems to like to freeze everything up.
> After re-reading your message, you _are_ able to connect and backup directly to a Samba share?  did you do anything special, for I can not using BE8.5 and 
> RH7.3/Samba2.2.8a  My only solution is to rsync it over to the BE server.  If you can shed anylight, I would be much appreciative.

I am using Backup Exec 8.6 to backup a Redhat server for three years. I
use the Unix agent instead of trying to backup via Samba. The server was
initially setup with Rh7 and was upgraded to 7.2 then 8.0 The Unix BE
agent has worked flawlessly the entire time.

More information about the samba mailing list