[Samba] Samba 3 problems with file read/writes

Lindsay Haisley fmouse at fmp.com
Mon Aug 25 19:03:11 GMT 2003

I just updated my web server box, running Debian testing, to samba v3, and
am having some problems with a share.  Can anyone advise me on this?

I have a share called "allsrvr" which is defined in my smb.conf file as
follows.  Please note that security isn't an issue here.  The server is
connected to my home system via a VPN and all smb/cifs ports are closed to
the world at the router at my colocation, so I can be liberal with my

        hosts allow = all
        admin users = fmouse, cheryl, mnature, cdbooks
        path = /
        mangle case = yes  
        preserve case = yes
        writable = true
        dos filemode = yes

I can mount this share OK, and do simple file operations, but something
changed between Samba 2 and Samba 3 which makes file operations from my HTML
editor, HomeSite, go south, although they worked fine with Samba 2. 
Homesite modifies files on the server using a samba share.  It makes a
temporary working copy of a file in the same directory as the live copy,
prefixed with "~hs".  The built-in browser (IE) accesses this file and
updates whenever characters are typed in the code editor pane.  The
temporary file is apparently not being created, or is getting created with
less than all the data, and saves back to the live file often end up with a
zero length file, trashing all the work that's gone into it :-(

My log.smb shows entries such as the following:

[2003/08/25 11:25:19, 0] lib/util_sock.c:read_socket_data(342)
  read_socket_data: recv failure for 4. Error = Connection reset by peer
[2003/08/25 11:25:19, 1] smbd/service.c:close_cnum(873)
  humbug ( closed connection to service allsrvr

humbug is the name of the win box.  On the Windows side, I get a non-helpful
"I/O error" and then a notice that "another process has modified the file. 
Reload?" and if I say yes, I get the zero length file loaded.

I've tried mucking with various lock and caching parameters in smb.conf with
no luck.  This all worked fine with Samba 2.  Can anyone give me any help? 
I'll be glad to try anything and report the results.

Lindsay Haisley       | "Everything works    |     PGP public key
FMP Computer Services |       if you let it" |      available at
512-259-1190          |    (The Roadie)      | <http://www.fmp.com/pubkeys>
http://www.fmp.com    |                      |

More information about the samba mailing list