[Samba] Re: Re: Ref: Samba + Cups: don't succeed to print from Windows 2000 station

nadine.vandois at bull.net nadine.vandois at bull.net
Thu Aug 21 14:04:12 GMT 2003

Hello Dragan,

I looked at your smb.conf, modified mine and tried again .
I always got the same error.
So I decided to look at internet, to find new information about cup and
samba, to better understand how cups and samba work and their architecture.
I notably found 'Printing Support in Samba 3.0' and 'tutorial on cups and
foomatic (kongress 2002)'.

When reading, I made again some modifications in smb.conf.

Above all, I think it was at least a problem with the spool samba
directory. It was defined in smb.conf, but the directory did not exist !

With all these modifications, I can now print from Windows NT client (I
still have problems with W2000 and XP: I continue on reading, may it is a
problem of drivers).
In fact, I repeat the same install on Suse 8.2, after doing it on RH 9.0,
which works better up to now).

The more satisfactory is that I have made some progress,and it starts

Thank you for your support and for your help.


---------------------- Réacheminé par Nadine Vandois/FR/BULL sur 21/08/2003
15:39 ---------------------------

"Dragan Krnic" <dkrnic at lycos.com> sur 14/08/2003 18:55:41

Veuillez répondre à dkrnic at lycos.com

Pour : nadine.vandois at bull.net
cc :   samba at lists.samba.org
Objet :     Re: Ref: Samba + Cups: don't succeed to print from Windows 2000

> I took into account your answer.
> I installed and recompiled samba 2.2.8a.
> I didn't load glibc2 (which is not delivered with
> the Suse distribution), but all seems to be OK.
> I then tried rpcclient with: enumdrivers,
> getdriver.It works fine now.
> But I still have problems when asking to print from
> a windows station. The window station find the
> printer, but when I ask to print a document or the
> test page,I get:
> Impossible to print: problem of configuration of
> printer.
> Try ..............
> and:
> Test page could not be printed. Do you want .....
> On my Linux server, I can print from the samba guest
> user: cups_samba_entry.
> Do you think it is a problem with cups or with
> samba ? >What can I do or test ?

Hi Nadine,

I have edited your smb.conf to best match my own setup.
Lines beginning with "-" sign should be commented out.
By most of them there is a short comment why. Lines
beginning with "+" sign are new lines I added to make
it look more like my setup.

It should work at your side, but don't forget to first
create the default mode by accessing the printer as
root and performing the ritual I described in on of my
previous letters.

Good luck.

Get advanced SPAM filtering on Webmail or POP Mail ... Get Lycos Mail!

More information about the samba mailing list