[Samba] passwd not running as root

sranetworking at swiftdsl.com.au sranetworking at swiftdsl.com.au
Wed Aug 20 07:11:30 GMT 2003

Hi all,

I posted a message about this problem a couple of weeks ago without a
response so I'm trying again.  My problem is that samba does not seem to
be running passwd as root when it tries to sync the passwords.  For
example, when I run smbpasswd as a user logged onto the samba box I get
the following error:

machine rejected the password change: Error was : RAP86: The
specified password is invalid.
Failed to change password for it

When I check the logs after enabling passwd chat debug I find:

[2003/08/06 15:15:36, 10] smbd/chgpasswd.c:dochild(217)
  Invoking '/usr/bin/passwd it' as password change program.
[2003/08/06 15:15:36, 0] lib/util_sock.c:read_socket_with_timeout(279)
  read_socket_with_timeout: timeout read. read error = Input/output
[2003/08/06 15:15:36, 100] smbd/chgpasswd.c:expect(271)
  expect: expected [*New*password*] received [passwd: Only root can
specify a user name.
  ] match no
[2003/08/06 15:15:36, 2] smbd/chgpasswd.c:expect(277)
  expect: Input/output error
[2003/08/06 15:15:36, 3] smbd/chgpasswd.c:talktochild(308)
  Response 1 incorrect
[2003/08/06 15:15:36, 3] smbd/chgpasswd.c:chat_with_program(376)
  Child failed to change password: it
[2003/08/06 15:15:36, 3] smbd/chgpasswd.c:chat_with_program(421)
  The status of the process exiting was 64768

The relevant smb.conf settings are:

unix password sync = yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd*
passwd chat debug = yes

I've tried this now with RH 9.0 and samba 3 RC1, beta 3 and beta 1 with
the same results.

Any insights would be much appreciated.  Thanks, Mike.

More information about the samba mailing list