[Samba] Samba 3.0b3: Cannot add machine to LDAP database

Ralph Angenendt ra at br-online.de
Tue Aug 12 11:37:00 GMT 2003

romeo adekambi wrote:
> Gonçal Badenes wrote:
>>[root at ICFO-pc038 root]# pdbedit -a -m icfo-pc018
>>failed to add user dn= uid=icfo-pc018$,ou=Systems,dc=icfo,dc=es with: 
>>Object class violation
>>object class 'sambaSamAccount' requires attribute 'sambaSID' failed to
>>modify/add user with uid = icfo-pc018$ (dn =
>>Unable to add machine! (does it already exist?)
>>[root at ICFO-pc038 root]# smbpasswd -a -m icfo-pc018
>>Failed initialise SAM_ACCOUNT for user icfo-pc018$.
>>Failed to modify password entry for user icfo-pc018$
> have u got a posix attribut pour le machine ?
> try this before your pdbedit :
> useradd -s /bin/false -d /dev/null icfo-pc018$

That really shouldn't be needed when using LDAP as the passdb-Backend.

I get the same error, at least the smbpasswd -m -e -a machine has worked
in Samba 3.0beta2.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 192 bytes
Desc: not available
Url : http://lists.samba.org/archive/samba/attachments/20030812/7048c22b/attachment.bin

More information about the samba mailing list