[Samba] Re: Samba 3.0 PDC+LDAP

Damian Gerow damian at sentex.net
Mon Aug 11 01:47:39 GMT 2003

Thus spake paul k (paul at subsignal.org) [10/08/03 09:30]:
> Damian Gerow wrote:
>      return code = 0
> >
> >I can't see any groups, nor any group mappings.  Does anyone have any
> >up-to-date docs (even some notes) on setting up 3.0 to work with LDAP well?
> >
> >I had tried the import tool, but it didn't actually /do/ anything -- I 
> >could
> >see the LDAP searches, but not the additions.
> What did you do to set up groupmapping?

Nothing yet.  I'm moving from the smbpasswd backend, and it 'just worked' in
there.  That's why I was asking for some docs -- I'm sure this is something
that I'm missing, but I just don't know what.

If I do /any/ sort of group mappings at all, I get this:

    [2003/08/10 21:45:44, 2] lib/interface.c:add_interfac79)
      added interface ip= bcast= nmask=
    [2003/08/10 21:45:44, 2] lib/smbldap.c:smbldap_search_domain_inf1228)
      Searching for:objectClass=sambaDomainsambaDomainName=SENTEX))]
    [2003/08/10 21:45:44, 2] lib/smbldap.c:smbldap_search_suffi1056)
      smbldap_search_suffix: searching for:objectClass=sambaDomainsambaDomainName=SENTEX))]
    [2003/08/10 21:45:44, 2] lib/smbldap.c:smbldap_open_connectio623)
      smbldap_open_connection: connection opened
    [2003/08/10 21:45:44, 2] passdb/pdb_ldap.c:ldapsam_search_one_grou1619)
      ldapsam_search_one_group: searching for:objectClass=sambaGroupMappingdisplayName=Domain Adminscn=Domain Admins)))]
    NT Group Domain Admins doesn't exist in mapping DB
    [2003/08/10 21:45:44, 2] utils/net.c:mai683)
      return code = -1

So I'm not sure what it's looking for in LDAP -- something with a cn of
Domain\ Admins?  But where?  And why can't I add the group via 'net group

More information about the samba mailing list