[Samba] Re: Samba Question

Will Froning wfroning at uop.edu
Wed Aug 6 20:40:39 GMT 2003

I'm using FreeBSD 4.8 so software install will be quite different and
rather trivial.

My first step involved making sure the DC's were in /etc/hosts with
shortname entries.

Next I installed openldap22, then heimdal-kerberos (found some post
about this being the better/preferred version).  When I installed krb5 I
made sure to include with-ldap as a config option (this was the real
solution).  Finally I installed Samba 3.0b3 and it worked.

The crazy part was when I forgot to add the config flag for krb5, ADS
support was compiled in, but the krb5 keys didn't work right.  So all
the'net ads lookup' stuff worked, but I couldn't get the right creds to
join the domain.  The krb5 recompile solved it.

If you need more info, just ask.


> I read your post, and the error messages you were getting on the 'net
> join' command are pretty much the exact thing I'm getting.
> Can you please elaborate on what you did to fix it?  What
> version/dist. of kerberos, what flags to compile it?
> I'm using SuSE 8.2 professional, samba 3.0 b3, and have been trying
> the MIT version of kerberos (1.3.1).

Will Froning
Unix Sys. Admin.
wfroning at uop.edu

More information about the samba mailing list