[Samba] final tests fail with samba...can anyone help?

Stephen P. Villano wizard_1 at comcast.net
Sun Apr 27 02:48:46 GMT 2003

Is Windows 2000 running in mixed mode or native mode?
I *KNOW* that the 2.0.x series worked quite well with W2K in mixed mode.
>From my recollection though, in native mode was quite ineffective as native
mode (correct me if I'm incorrect in my recollection, people) ignores port
139 netbios calls in favor of the new NBT port.
I'm a bit rusty though as I've been running the beta 3 for quite a while
(excellent work, people! A little more work and life'll be joyful without a
NT4/NT5 server around!).

----- Original Message -----
From: wittling - softhome account <wittling at softhome.net>
To: <samba at samba.anu.edu.au>
Sent: Saturday, April 26, 2003 3:23 PM
Subject: [Samba] final tests fail with samba...can anyone help?


I just took an old PC and installed SuSE 7.0 on it. The machine has 32Mb of
RAM, so I needed a slim installation and kernel, and this was the only
package I could get to install without immense effort (I tried 5 other
versions of small linux distros from linuxiso.org before this one).

The version of Samba I installed on this Suse box is 2.0.7. From what I have
read, this version SHOULD work with Windows 2000. I had to look hard to find
it on the SuSE site, because they have mothballed it off into an
"obsolete/unsupported" directory. I was just glad to find it, since newer
versions of the samba product fail the dependency checks on the rpm
installer and would not work. Eventually, I may update to more recent code,
but I didn't want to upgrade the entire system (yet) for the sake of getting
samba to work. I guess I should also mention that I am aware of the patches
and fixes for the product since 2.0.7.

I have run all of the tests in the DIAGNOSIS file, and all appear to work
except for the last 2...which of course are the most important.

On the Windows side, I know sharing works because I share with a laptop
quite frequently. NBTSTAT comes back fine with the Samba directory
When I run Net View \\SERVERNAME I get:
System error 53 has occurred.

The network path was not found.

When I run Net Use X: \\SERVERNAME\tmp I get the same thing.

On the Linux side....
* if I run nmblookup -A [WINDOWSSERVERNAME]....all comes back perfectly.
* The samba client connects to itself just fine.
* if I run smbclient -M [WINDOWSSERVERNAME]...and type in a message...I see
the dialogue on windows!

* if I run smbclient -L [WINDOWSSERVERNAME], I get the following:

Connecting to [IP] at port 139
write_socket(3,76) wrote 76
Sent session request
got smb length of 1
session request to *SMBSERVER failed (Not listening on called name)

Anyone have any clues here? I am about out of gas on time and energy on this
one and could use some help...
To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list