[Samba] Word problem with large uid/gid

Andrew Bartlett abartlet at samba.org
Fri Apr 25 15:23:39 GMT 2003

On Fri, 2003-04-25 at 23:16, Johan Coenen wrote:
> Hi,
> We've noticed the following problem:
> Samba server:
> RedHat 7.3
> Linux version 2.4.18-3 (bhcompile at daffy.perf.redhat.com)
> (gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-110))
> Samba 2.2.8a
> 1 user defined
> 1 share defined
> (it's a test-setup, server is a Dell ProLiant 2600 and isn't used for 
> anything else)
> Client PC: Windows XP/Office97 and Windows2000/Office97
> IF 	uid or gid of user > 65.535
> AND	samba loglevel > 2
> THEN 	I have problems with saving word documents
> errors on client: "disk full" "read-only" etc...
> Well, you might suggest that if that's our problem, we should use small 
> uids/gids or shouldn't set the log-level higher than 2.
> But the problem is that in our production environment, despite the fact 
> that log levels are set to 1, some users are sometimes having the same 
> problem with saving word-documents (Word97, Word2k and WordXP). Some do 
> have large uid's en practically all are having large gid's
> We tried all Samba versions 2.2.3 up to 2.2.8a, tried RH7.1, RH7.3, XFS 
> 1.0.1, XFS 1.1 and now Ext3
> Colleagues of mine are saying "it can't be the kernel. It must be something 
> in the Samba code"
> Is there a reasonable explanation why, in our test-setup, log level 1 and 2 
> don't give a problem, and all the other levels do?

Not sure about the log level stuff, but try your recent glibc security
upgrade for the problem :-)

Well, that's what I blamed - as soon as I backed down the update (this
was in 8.0, but 7.3 might have the same issue) it stopped happening.  I
have a RedHat bug out against glibc
(https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=86534), but have
not had the testing resources to verify what they thought might be a fix
(breaking my production environment again would not go down well).

Anything in the logfiles?  I was getting assert_uid() failures.

Andrew Bartlett

Andrew Bartlett                                 abartlet at pcug.org.au
Manager, Authentication Subsystems, Samba Team  abartlet at samba.org
Student Network Administrator, Hawker College   abartlet at hawkerc.net
http://samba.org     http://build.samba.org     http://hawkerc.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20030426/21eca12b/attachment.bin

More information about the samba mailing list