[Samba] rpcclient (adddriver: move_driver to_download_area, fail)

Lars Göransson larg at spray.se
Wed Apr 23 12:29:12 GMT 2003

I have som trouble with rpcclient..

I have all my adobe-drivers in /usr/share/cups/drivers/ 
and a directory in /etc/samba/drivers for the targetdrivers after i run

But when i run cupsaddsmb, directorys named  Win40 and W32X86 in /etc/samba/drivers
is created. And the files from /usr/share/cups/drivers in the directorys.

But when cupsaddsmb is running "adddriver..." it fails. This
is what is written in the logfile when adddriver is executed :

 --SNIP-- move_driver_to_download_area: Unable to rename [WIN40/ADOBEPS4.DRV]
to [WIN40/0/ADOBEPS4.DRV] move_driver_to_download_area: Unable to rename
[W32X86/ADOBEPS5.DLL] to [W32X8 6/2/ADOBEPS5.DLL] 


It seems to be some wrong when its going to mkdir /2/ and /0/ and copy
the files to the dirs. 

When this is executed, is that when the drivers is written to the *.tdb-files

I can do mkdir by hand if I connect with smbclient //borprintx1/print\$
-N -U 'root%secret' . So I guess that all permissions is ok. 

Does anyone know how to solve this problem? 

Thanx Lars

Här börjar internet!
Skaffa gratis e-mail och gratis internet på http://www.spray.se

Hitta rätt på internet med Lycos -  http://lycos.spray.se

More information about the samba mailing list