[Samba] Re: samba not working

Dan Shadix dshadix at trhs.org
Mon Apr 14 13:50:45 GMT 2003

Did you make sure that iptables or ipchains isn't blocking access from the Windows boxes?  The first line of step 10 says "Is there a firewall running on the Samba server? Note that this happens more often than not! ;-)".  The default setup of RH8 will block SMB.

---------- Original Message ----------------------------------
From: "Bruce Faulkner" <bruce at faulkner.ws>
Date:  Sun, 13 Apr 2003 21:38:15 -0600

>Richard, Ralph:
>    I'm having this very same problem and have been now for a couple of
>months, ever since I purchased Redhat 8.0 Pro and installed it.  I have two
>samba boxes on two different networks.  One of them at work and is:
>RedHat Linux 8.0
>Samba 2.2.5
>the other at home and is:
>RedHat Linux 8.0
>Samba 2.2.8
>Both of the computers on both networks are on the inside of the firewall.
>On the Win95 system I unplugged the router (firewall) from the hub in case
>it had some influence but it didn't help.
>I've tried different samba config files, even the one from the Unofficial
>Samba Web Site and one from a friend that is successfully running samba.  On
>the Unofficial Samba Web Site they have a trouble shooting section.  All of
>the tests pass up through the first half of step six.  The second half of
>step six does not work and the second half of step seven doesn't work.  The
>first half of step seven does work.  I haven't tried any further steps.  I
>can connect to and view files on the Win95 computer from the Linux computer.
>They don't offer any solutions if any steps in the troubleshooting doesn't
>I hope someone has the answers for both of us.
>Bruce Faulkner
>----- Original Message -----
>From: "richard" <rcoates at bigpond.net.au>
>To: "Ralph Bard" <ralph at willowtec.com>
>Cc: <samba at lists.samba.org>
>Sent: Sunday, April 13, 2003 3:04 AM
>Subject: Re: [Samba] Re: samba not working
>> don't forget built in Xp firewall?
>> On Sun, 2003-04-13 at 02:17, Ralph Bard wrote:
>> > I'm having exactly the same problem and I've tried from W2K Server as
>> > as XP Pro. Samba is 2.2.8a on RedHat 8. From the windows side you can
>> > "nbtstat -A ipaddr" and doing so against the windows machine works. It
>> > back with "host not found" when pointed at the linux box but it's
>> > telnet, ftp etc, everything I've turned on is there. This message is
>> > supposed to indicate there is something blocking the port(s) 137-139 but
>> > nothing is behind a firewall.
>> >
>> > I could not find swat and other basic utilities from the RH8 default smb
>> > installation, so I downloaded and rebuilt samba. Everything is there,
>> > fires up and makes changes properly etc but no change from the windows
>> > I'm completely at a loss now - the machine shows up on the browser list
>> > won't open to show any shares.
>> >
>> > -Ralph
>> >
>> >
>> > "blaschke" <blaschke at wisd.net> wrote in message
>> > news:1050031265.3e9634a117a09 at www.wisd.net...
>> > > I have been trying for a while to get samba operational from the
>> > > neighborhood side of things.
>> > >
>> > > I can use the command line interface from within my linux box and I
>> > > access
>> > > the shares, but when I try it through network neighborhood, it tells
>> > > network path not found.
>> > >
>> > > Any clues?
>> > >
>> > > I am running redhat linux 7.3 and samba version 2.2.8
>> > >
>> > > James B.
>> > >
>> > > --
>> > > To unsubscribe from this list go to the following URL and read the
>> > > instructions:  http://lists.samba.org/mailman/listinfo/samba
>> > >
>> >
>> >
>To unsubscribe from this list go to the following URL and read the
>instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list