[Samba] Group mapping problem - please help

Damir Dezeljin programing at mbss.org
Thu Apr 10 07:13:08 GMT 2003


I'm using Samba 2.2.7a-security-rollup-fix (RH-9.0) as member of WinNT4
domain. I joined samba to the domain. I configured the winbind daemon and
nsswitch switch to map NT users to unix users.

Then I set ACL support on an ext3 partition and share the mount point of
this partition with ACL Samba support:
- my share is [test_share]
- the directory is /mnt/test_dir

  path = /mnt/test_dir
  writeable = yes
  browsable = yes
  hide unreadable = yes
  nt acl support = yes
  inherit acls = yes
  inherit permissions = yes
  valid users = @my_group
  invalid users = root

# ls -ald /mnt/test_dir
drwxrws--- 3 root my_group  4096 Apr 10 00:00 /mnt/test_dir

I set up the my_group in /etc/group as folows:

Then I tried to connect to this share as PDC\user01, but I got an error (I
got an dialog box asking for my password). Then I tried to 'su' into this
user (# su - PDC\\user01) in the Linux terminal and try to access this
directory - this works without any problem.

So I enable Samba debugging and set 'log level = 4'. When I checked the
log files, I noticed that samba resolve the user PDC\user01 only to be
member of 'Domain Users' group and didn't see that it is also part of

Any hint how to solve this problem?


More information about the samba mailing list