[Samba] Samba and Ldap Groups

Bradley W. Langhorst brad at langhorst.com
Wed Apr 9 13:54:20 GMT 2003

On Wed, 2003-04-09 at 03:44, Kristyan Osborne wrote:
> Hi,
> Still no luck, I have given access to everything in the LDAP directory to everyone and I still get the same error message. Do I need to specify somewhere/somehow if normal users and access the LDAP directory??
> >[2003/04/08 13:30:19, 0] passdb/pdb_ldap.c:ldapsam_search_one_group(2198)
> >  ldapsam_search_one_group: Problem during the LDAP search: LDAP error:  (Insufficient access)ldapsam_open: cannot access LDAP when not root..
> >[2003/04/08 13:30:19, 0] passdb/pdb_ldap.c:ldapsam_retry_open(509)
> >  Connection to LDAP Server failed for the 1 try!
> >[2003/04/08 13:30:19, 0] passdb/pdb_ldap.c:ldapsam_setsamgrent(2567)
> >  LDAP search failed: Insufficient access
> >[2003/04/08 13:30:19, 0] passdb/pdb_ldap.c:ldapsam_enum_group_mapping(2629)
> >  Unable to open passdb

start debugging ldap using the command line tools (not samba)
does ldapsearch -x work?

post relevant sections of your smb.conf file and your slapd.conf file
maybe I'll see an error.

did you set the ldap admin password in samba
smbpasswd -w i think

Bradley W. Langhorst <brad at langhorst.com>

More information about the samba mailing list