[Samba] machine account not accessible

Ingo Kappler kappler at pt.rwth-aachen.de
Tue Apr 8 21:21:25 GMT 2003


I'm setting up a PDC, but joining the clients (w2k, nt4) fails.

I use this in smb.conf:
add user script = add user script = /usr/sbin/useradd -d /dev/null -g 100 -s /bin/false -M %u

Just using the script I get the error: "no account in domain" under 
linux. Useradd itself works but it seems to fail for samba.
All clients originally used a nt4 PDC. Now this nt4 PDC must be changed 
to a samba PDC (samba 2.2.7a and 2.2.8 a bit later).

I tried to create a machine account manually to figure out how it works. 
After adding the entries manually with:

test:~ # passwd -u r13-4$
passwd: Unknown user r13-4$
test:~ # /usr/sbin/useradd -g 100 -d /dev/null -c "Tutoren-r13-4" -s 
/bin/false r13-4$
web:~ # passwd -l r13-4$
Password changed.
test:~ # smbpasswd -a -m r13-4
Added user r13-4$.

Windows still says something like: account not existing or wrong 
password (original message in german). I looked already in 
Samba-PDC-HOWTO.html. Probably it's the same error like: "/The machine 
trust account for this computer either does not exist or is not 
accessible./" What does "Ensure the domain admin user system is 
working." exactly mean?

I must get this running, thanks for any help or hint.

Ingo Kappler

Ps: I just found this in /var/log/samba.r13-3:

[2002/08/24 17:02:57, 0] rpc_server/srv_netlog_nt.c:get_md4pw(154)
  get_md4pw: Workstation r13-3$: no account in domain
[2002/08/24 17:33:25, 0] param/params.c:OpenConfFile(539)
  params.c:OpenConfFile() - Unable to open configuration file 
        No such file or directory
[2002/08/26 08:53:37, 0] rpc_server/srv_netlog_nt.c:get_md4pw(176)
  get_md4pw: Workstation r13-3$: no account in domain

More information about the samba mailing list