[Samba] 2.2.8: browsing and accessing Sun from Windows XP

Brian C. Hill bchill at bch.net
Fri Apr 4 22:02:28 GMT 2003



	I have followed BROWSING.txt exactly on setting up WINS to
assist with browse list collection. I set up a workgroup that just
includes a bunch of Suns running Samba 2.2.8 across about 6 networks.

	$ smbclient -L <domain_master_browser_host> -U %

run on the domain master browser shows all of the hosts on the 6
different networks after a while. Great. And from an XP system on one
of those networks, I can click on a the "Microsoft Windows Network" and
see the Workgroup. BUT, when I click on it, the hourglass comes up after
a while and just says

	<workgroup> is not accessible - maybe you do not have permissions
	to access it

	The account is not authorized to login from this host.

On a Win98 system, I can open up the workgroup and see the hosts, but I
get the same error when I try to click on a host.  I added

	map to guest = bad password

to smb.conf, but this did not help (my XP login and Sun login are the
same). Debugging on smbd turned up to 10 and snoops show no traffic to
the DMB (I didn't expect any, but I didn't know what else to try).


	I tried using map network drive with the fqdn


and it immediately fails wit the same message. Debugging on smbd turned
up to 10 and snoops show 'stuff' this time, but the smbd logs show
nothing that seems like an error or related to failed authentication in
any way. Snoop show a little traffic, including the stage where XP
tries to authenticate from HTTP (a little strange, but ok).

	I also have PlainTextPassword enabled.

	I don't get it. I have read everything I can. This has
to be something simple that I either set up incorrectly/incompletely,
or I am expecting this to work when it is not supposed to.

	I would appreciate any clues. I can send the snoop output or
the smb logs, if anyone wants to see them.



More information about the samba mailing list