[Samba] 2.2.1a / 2.2.2 bug is back in 2.2.8

Tom Schaefer tom at umsl.edu
Fri Apr 4 20:16:59 GMT 2003


Back when 2.2.2 was the current samba release I came across the following problem when deleting folders in Windows 2000 which I'll repost again below.  After I finally got his attention with a few very wordy messages to the samba mailing list, Jeremy fixed it blazingly fast and wrote me back:

"I just found the problem and fixed it in 2.2 CVS and HEAD CVS. It was
to do with the requested share mode not being propagated into an open
directory file struct, and thus the set of the "delete on close" buit
was being denied by an internal check."

Well the problem is back in 2.2.8.  I downgraded back to 2.2.7 on a test system to see if maybe it had been present in 2.2.7 and I just hadn't noticed.  Nope, 2.2.7 is fine, its just back in 2.2.8, I have several sambas running on several servers.

Here's the portion of my original posting from Nov. of 2001 explaining how to duplicate the problem.  Its the same story again with samba 2.2.8, well actually just slightly different in the error response from Windows, I'll explain at the end of problem recreation description.  The procedure below is with Windows 2000, Windows 98 didn't have the problem back with samba 2.2.1a/2.2.2 and it doesn't seem to now either.  I don't know about any other Windows versions:

Using Windows Explorer, Explore a drive mapped to Samba share or just
explore the share itself, it doesn't really need to be mapped.  The
key is to be exploring it it in Windows Explorer.

Ok, so you're in Windows Explorer exploring a Samba share or drive
mapped to a Samba share.  The problem is in deleting a folder.  If
there isn't a folder you can delete, make one.

On the left pane of Windows Explorer you've got all the little yellow
folders and plus signs next to them so you can expand them, and then
the contents of the current folder are displayed in the right pane.

IN THE LEFT PANE, left click once on the folder you want to delete.
Its name will be highlighted and THE LITTLE YELLOW FOLDER ICON JUST TO
THE LEFT OF ITS NAME WILL BE OPEN and the contents of the folder are
displayed in the right pane.
Press the delete key on the keyboard or pointing at the folder name in
the left pane press the right mouse button and select delete from the
drop down menu.

Everything (if anything) in the folder will be deleted but not the
folder itself.  You'll get "Error Deleting File or Folder, Cannot
remove folder xxxx: Access is denied, the souce file may be in use." 
Click OK so the error goes away, then try deleting the folder a second
time and it will then delete.

The paragraph immediately above this one was the error you'd get in 2.2.1a and 2.2.2.  Now, with 2.2.8 the error behaviour is a bit different:  The folder will in fact be deleted on the first attempt but you'll get this error message as it completes the deletion: "Cannot remove folder whatever: cannot find the specified file, make sure you specify the correct path and filenames".  You click ok and the error goes away and it gets really weird right here right now: If the folder you tried to delete had no subfolders then you click OK on the error and the folder dissapears from Windows Explorer, it should, it has in fact been deleted.  If the folder had subfolders, you click ok and the error message disappears but the folder name does not disappear from Windows Explorer, even though it actually has been deleted, and no amount of clicking View/Refresh will make it disappear.

Tom Schaefer

More information about the samba mailing list