[Samba] "Password expires today" error on WinXP & 2000 with Samba PDC

danfry at btinternet.com danfry at btinternet.com
Fri Sep 27 08:52:01 GMT 2002


I'm running Samba 2.2.5 on Red Hat Linux 7.3, set up as a PDC. Logging in from Windows 95, 98 and ME all work fine; 2000 and XP give a "Password expires today" error every time, even if the password is changed.

I have been through the archives several times and found a couple of instances of this problem but:
- I have the X in the smbpasswd file (the section [UX     ])
- I'm not using LDAP (at least, there is no slapd on my system - I don't know much about LDAP)
- I have applied the signorseal registry patch on the clients
- I've tried changing the Unix password expiry date
- I've tried *removing* the X from the field in the smbpasswd file
- I upgraded from Samba 2.2.3a to 2.2.5 using the appropriate binary RPM from samba.org (same problem occurs). This will be a production server so I'd prefer not to compile from CVS if possible
- I did a clean install of Windows XP on the client and RH 7.3 on the server

Any help would be greatly appreciated!

(BTW: apologies if this is the wrong way to use a mailing list - it's my first post to any list ever, I always try to solve a problem myself first)

Many thanks

Dan Fry
danfry at btinternet.com

More information about the samba mailing list